Requirements

There are some requirements that your system/server should support...

Server
1. PHP 5.2.0 or higher
2. URL Rewrite Module (Apache or IIS)

System
Joomla! 1.5 for AceSEF 1.5
Joomla! 2.5 for AceSEF 2.5

Configuration
You should also set to YES the SEF and mod_rewrite options in Global Configuration:

global-configuration    global-configuration

The suffix option is not important because you’ll set it from AceSEF Configuration.

The default Joomla!’s htaccess is enought for AceSEF, so just rename it from htaccess.txt to .htaccess